VERIFIED SOLUTION i

How to know which versions can be skipped over when updating to the newest version of MailStream Plus software

Products affected:  MailStream Plus

Operating System: All Platforms
Required changes for each MailStream Plus (MSP) version are listed in the 'Release Notes' for that version.

Each progressive version of MSP does not need to be installed, but any changes required for each of the bypassed versions for the computer platform being used must be done. 
This is because for each release there may be changes required.  These changes are listed in the Release Notes for each version, and are not listed again in Release Notes for later versions.

For all platforms (except IBMi):
--------------------------------
Changes may be required in the jobs/scripts to add or delete DD statements, or change the size of files, or parameter changes.
Say MSP 8.3.0 is currently being used, and upgrading to 8.3.3 is wanted.  Do 8.3.1 and 8.3.2 need to be installed first, before installing 8.3.3?
No.  They do not actually have to be installed, but the Release Notes for any skipped versions must be reviewed for any changes that were required, and those must be made in the jobs.
In this case any job/parameter changes that were required for version 8.3.1 would have to be made.
Then any job/parameter changes that were required for version 8.3.2 have to be made.
And finally any required changes for 8.3.3 must be made.

For the IBMi platform: 
---------------------- 
The IBMi MSP releases have a forwarding program that makes the actual job script changes such as new or removed files.  The forwarding program will forward jobs from several releases back, so even if the installation of several versions were skipped, the forwarding program will bring the job scripts up-to-date. 
But in many cases the forwarding program cannot make changes to actual parameters, because they may be new, or values changed, so the jobs will have to be edited to make those changes.  This can normally be done using the CHUI screens.
Say MSP 8.3.0 is currently being used, and upgrading to 8.3.3 is wanted.  Do 8.3.1 and 8.3.2 need to be installed first, before installing 8.3.3?
No.  They do not actually have to be installed, but the Release Notes for any skipped versions must be reviewed for any parameter changes that were required, and those must be made in the jobs.
So once 8.3.3 is installed, then any parameter changes that were required per the 8.3.1 Release Notes would have to be made.
Then likewise any parameter changes that were required per the 8.3.2 Release Notes have to be made.
And finally any changes for the 8.3.3 release can be made.
 
UPDATED:  April 14, 2017