VERIFIED SOLUTION i
X

How to use MapInfo Pro to create buffers around a table of symbols

UPDATED: November 1, 2017


A set of buffers, often referred to as rings or circles, can be created around a table of symbols (point objects) that can represent store locations, distribution centers, cell towers, ATM machines, customer locations, etc.

Buffers are a powerful GIS tool, allowing users to run simple queries, such as find all of the customers within a chosen radius from a location
(i.e. find all the customers within 5 miles of each Store in a table, etc.)

The following steps show how to create 5 mile buffers around a table of symbols that represent a set of Stores.
The table of point objects are called "Stores" and the Buffers created around them will be named "FiveMileBuffersOfStores"
Any underlying data in the Stores table will be brought into the new FiveMileBuffersOfStores table when created.

The fact that in this method the buffers inherit the Store data that the buffers are based on is extremely important, as it allows users to run queries, distance calculations, etc. and most importantly, be able to tell which specific Store's buffer is returned or analyzed.
In the example above, this would allow a user to find, for example, all of the customers (from a Customer table) within a given radius to each Store AND know in which Store's buffers those customers are located.

The alternative buffer creation method (Object > Buffer) creates similar buffer objects as Table > Buffer but those map objects (buffers) do not contain any data from the point object being buffered, thus preventing the powerful queries and analysis possibilities available when the buffer does contain attribute data from the parent point object (i.e. Stores in the example above)
 
Each record in the Stores browser corresponds to each point (red pushpin) in the Map Window.

User-added image
 
User-added image
 
1.  Choose Spatial tab>Edit>Buffer>Buffer Table.
2.  Select the point table and store the buffers in a New table.  Click Next.

User-added image
 
3.  Select Add to Current Mapper.  At the bottom of the dialog, select Using Table for the Table Structure and select the Stores table from the drop-down.  Click Create.
User-added image
 
4.  In the New Table Structure dialog, accept the default table structure and click Create.
Note: it is extremely important to make no changes to the table structure at this point to avoid having to manually correlate
each field at the Data Aggregation dialog..

User-added image
 
5.  Name the new table, select a folder location, and click Save.
User-added image
 
6.  For  this example, specify a Value of 5 and Units of miles for the Radius.  Change the Smoothness to 30.  The higher the number entered will result in a smoother buffer up to a value of 100.
Select "One buffer for each object".  Click Next.
User-added image
 
7.  Accept the default values and click OK.
User-added image
 
8.  The 5 mile buffers will be created and added to the Map Window.
User-added image

 
9.  To make the buffers transparent, while all the buffers are still selected (highlighted in red), choose Spatial tab>Create>Style>Region Style.  Change the fill Pattern to “N”  for None.  Make any other changes desired and click OK.
User-added image
 
10.  Click Map tab>Content>Clear.  Then go to Home tab>File>Save>Save Table to save the changes to the new FiveMileBuffersOfStores table.
 
Each record in the FiveMileBuffersOfStores browser corresponds to each buffer in the Map Window.
User-added image

User-added image
 

 

Downloads

  • No Downloads