VERIFIED SOLUTION i
X

How to convert KMZ file to TAB file and TAB file to KMZ/KML file in MapInfo Pro

UPDATED: September 15, 2017


Details describing how to convert .KML/.KMZ to .Tab and .Tab to .KML/.KMZ

1. Convert google KML/KMZ to .TAB using MapInfo Pro.
 
  • In older 32-bit versions, go to file>open universal data
  • Select the file format required and the location of the file. Then Press OK. It will open the KML/KMZ file.
  • To save it in .TAB format go to File>Save copy as . This will save the file in .TAB format.
  • In newer versions such as 12.5 32bit, use Tools>Universal Translator.  The translator can directly make a Native .tab file by selecting a .KMZ/.KML and translate it to .tab.

2. To convert .TAB format file to KML/KMZ file format
  • Open the tab file by going to File>Open in 32-bit MapInfo Pro.  Use Home>Open Table in 64-bit.
  • Then in 32-bit, use Tools>Tool Manager and select Select ‘Google earth Utility Tool’ and click ‘OK’
  • For 64-bit, use Home>tool extensions>Register>click the icon to the right of the word "Autoload" to load the tool into the Running tab.  Then access the tool from that tab.
  • Then Right-click on the layer name in Explorer Window/Layer Control and choose "select all" from the layer. 
  • For 32-bit, go to Map>Google Earthlink> Export to Google Earth.  That will allow a .tab file to be saved.  If no selection is performed, only a .jpg image will be created.
  • For 64-bit, go to Home>tool extensions>Running and execute the tool.

Environment Details

Product affected: MapInfo Pro™
 

Downloads

  • No Downloads