VERIFIED SOLUTION i

How to find out if MAIL360 Data Manager 2.6.0 a required release

Is MAIL360 Data Manager 2.6.0 a required release?

No, MAIL360 Data Manager 2.6.0 has been released to add new software features.  But it is not a required release that users must install.
UPDATED:  April 21, 2017