VERIFIED SOLUTION i

How to resolve error message This Patch can not be applied to this version of MapInfo Professional

There are two main reasons why this message might appear:
 
  1. A 32 bit version patch is being applied to a 64 bit MapInfo Professional installation or vice versa. You can only apply 32 bit patches to 32 bit MapInfo Professional installation and 64 bit patches to 64 bit installations. Please ensure you download and apply the correct patch for your version of MapInfo Professional.
  2. The patch is for the right version but is being applied to a Beta version of MapInfo Professional. Download the full release of MapInfo Professional and then apply the patch (our patches are based on the full release of MapInfo Professional and not the Beta release).


 
Environment Details
Products affected: MapInfo Pro™, MapInfo Professional®
UPDATED:  July 14, 2017