VERIFIED SOLUTION i

Are previous versions of the MapInfo Pro compatible with the latest version of the License Server Utility?

Products Affected: MapInfo Pro, License Server Utility
The latest version of the License Server Utility can use used with previous versions of MapInfo Pro.

However with the latest version of MapInfo Pro, you will need to use the latest version of the License Server Utility. This will not work with older versions of the License Server.
UPDATED:  August 29, 2017