VERIFIED SOLUTION i

Supported Browser for EngageOne Server 3.X

EngageOne Version: 3.X

EngageOne Correspodent is only supported on Internet Explorer. Any other browser (Mozilla Firefox or Google Chrome etc) other than Internet Explorer is not supported.
For more information, please refer subsection 'EngageOne interactive' under section 'EngageOne Server system requirements' in EngageOne release notes shipped with the installer.

UPDATED:  May 1, 2019