VERIFIED SOLUTION i

Using SQL Server 2012 instead of SQL Server 2008 in EngageOne 3.X

If, as per documentation (Release notes), an EngageOne build/version is supported on SQL Server 2008, it will be supported on SQL Server 2012 as well.
UPDATED:  May 31, 2017