VERIFIED SOLUTION i

Custom Fields Missing From EngageOne Video Reporting Dashboard

This will likely affect custom deployment environments, but the general information surrounding the PHP extensions is valid across all environments.

Issue

Custom reporting or customer data fields, such as specific PURL data that requires an extension point to process may have worked on a pre-production environment but is not working on a production environment.

Cause

This is likely caused by the required extension files (either a ConsolidatedServiceUsageReport PHP class for the user dashboard, or a ServiceUsageReport PHP class for the visit dashboard reporting) being absent, causing the custom data fields to not be displayed or reported on in the relevant Dashboard CSV download.

Resolution

UPDATED: March 1, 2019
If the required fields are not present in the Dashboard CSV download while creating your project, implement the required classes.  There is more information on how to perform this step in the EngageOne Video documentation: https://admin.rtcvid.net/admin/docs/nav/nav-dev-reporting.htm

If you have updated your environment or deployed elsewhere, such as if you have moved from pre-production to production, the required extension point classes may not have migrated.  Simply take the existing classes you created for pre-production and place them in the correct location on the new deployment, as detailed in the documentation.

Please note that this will require a publish and redeployment.

For further assistance, please contact EngageOne Video's support team.