VERIFIED SOLUTION i

CSV or Dashboard Report Issues on An On-Premises Installation of EngageOne Video

On-premise installations of EngageOne Video, particularly non-clean installs of EngageOne Video on a Virtual server or box (such as out-of the box server solutions such as AWS).

Issue

One or more of issues may occur, such as:
  • CSV download of PURL or customer data will not return data, and will instead display 'Oops' in the first cell
  • The chart displays on the Reporting Dashboard will be missing, resulting in blank graphs

Cause

The cause is due to a MySQL query, ONLY_FULL_GROUP_BY being set to 'true' by default.  EngageOne Video Installations require this to be set to 'false' in order to behave as intended.

ONLY_FULL_GROUP_BY being set to 'true' is a default flag position for some versions of MySQL and not others.  MySQL 5.7 (version 5.7.5) and later versions have ONLY_FULL_GROUP_BY set to true by default. 

Resolution

UPDATED: December 5, 2018
Setting ONLY_FULL_GROUP_BY to 'false' should solve any issues caused by the flag being set to 'true'.  Please contact software.support@pb.com for further assistance with issues related to your version of MySQL and your on-premise installation of EngageOne Video.