VERIFIED SOLUTION i

Tiles are not caching after enabling Tile cache for WMTS in Spectrum Spatial Manager

Issue

After enabling Tile cache in Spatial Manager for WMTS, the tiles are not caching in specified folder:
User-added image

Cause

Few possibilities:

1. Writing permission to the specified folder

2. There are two tiling types in Spectrum Spatial i.e our own map tiling service and then the OGC standard called WMTS. 
There is some sharing between the two (WMTS used the named tile of our existing api) but the caching settings are separate. 
It is possible that caching is not enabled for our "traditional" tile service.

Resolution

UPDATED: December 10, 2018
1. Check if the specified folder has writing permission.

2. Clear the cache and try to restart the machine

3. If using the traditional tile service, the tile cache can be enabled in the MapTiling configuration piece in the Spatial Repository (Configuration folder) by editing the same with a WebDAV tool. 

You check the current state using the browser http://<host:port>/RepositoryService/repository/default and go Configuration and open the MapTilingConfiguration. 

It should look like this:
<Configuration xmlns="http://www.mapinfo.com/midev/service/configuration/maptiling/v1" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<Cache enabled="false">
<Property name="diskPath" value="C:/Program Files/Pitney Bowes/Spectrum/server/modules/spatial/TileCache"/>
<Property name="tilePathPattern" value="mapName/level/row"/>
<Property name="tileNamePattern" value="column.mimeType"/>
<Property name="zeroBasedTile" value="true"/>
</Cache>
<SrsBoundsList>
<SrsBounds srsName="epsg:27700" minX="0" minY="0" maxX="1300000" maxY="1300000"/>
</SrsBoundsList>
</Configuration>
If the Cache enabled="false", change the value to "true"
For more information about enabling Map Tiling Service cache, refer to the topic Enable the Pluggable Tile Cache
 
Environment Details
Product Affected: Spatial Manager
Product Feature: Map Tiling Service cache