VERIFIED SOLUTION i

Resolving the error 'The installer detected a newer version of the product. You need to uninstall the existing product before running this installation' when installing MailStream Plus on AIX

Product Affected:  MailStream Plus™
Product Feature: Installation / Upgrade
Operating System: AIX, UNIX, Linux

 

Issue

The following error message happens when trying to install the MailStream Plus™ version 8.3.7:
 
We have detected a prior production install in /pb/mailstream.
We will use the /pb/mailstream area for this install.
 
However, you may change the production location now, or you may install into a separate test location now.
 
Change the current production location or install into a separate test location?
(y)es - Install into a new production location or install into a separate test location.
(n)o - Install over current production location - default.
 
(y/n)==> n
 
Installing into production location /pb/mailstream
 
The installer detected a newer version of the product. You need to uninstall the existing product before running this installation.
 
Installation terminated

Cause

When installing MailStream Plus™ (MSP) and choosing to install into the production area, MSP checks the /opt/pitneybowes product registration area to see where the production software is installed. For example, if MSP is installed here:
/pb/mailstream.

Within the /pb/mailstream/msn/lib directory a file called msnrls was installed during the previous installation.
The contents of msnrls in the /group1/mailstream/msn/lib from the last installation show MSP 8.3.5 is currently installed:
        msn 08.03.05 F01 11/7/2017  AIX         00  N/A     A9.2.2    11/7/2017
        PRD RLS      MD  PVCSBLD    PLATFORM    PLM OSVER   COMVER    MEDDATE    DBCOMP

During the new installation process, files are ftp'd up to a directory.  One of the files sent up is the latest msnrls file. MSP verifies the current version above to the files in the ftp directory. If the file for the latest version is not ftp'd and an older one resides in this location, like this one for MSP 8.2.0, the error happens:
msn 08.02.00 A9.2.0

This indicates that MSP 8.2.0 is the version attempting to be installed, so it failed.  

 

Resolution

UPDATED: January 9, 2019
The MSP installation will fail because the file is from an older version.  The solution is to remove all files in the directory where files will be ftp'd directly to.
Then the software will only find files for the install version.  For MSP 8.3.7 the msnrls contents found should be:
msn 08.03.07 A9.2.2 

Now the software will install successfully.