VERIFIED SOLUTION i

Missing resources due to Purge when using EngageOne Server 4.4

Product Affected: EngageOne Server

Issue

This is to notify you of an important product issue which we have uncovered regarding the use of the Purge process within the following releases of EngageOne® Server:
  • EngageOne Server v4.4
  • EngageOne Server v4.4 SP1
  • EngageOne Server v4.4 SP2
  • EngageOne Server v4.4 SP3
  • EngageOne Server v4.4 SP4
  • EngageOne Server v4.4 SP5
  • EngageOne Server v4.4 SP6
 
If you are not using one of these versions, you can disregard this important notice.
The mentioned defect only affects environments where attachments are used. 

Cause

The issue occurs when purge process is executed causing the attachments database identifiers to be incorrectly inserted to the temporary table containing the identifiers of system resources which are about to be purged.
 

Resolution

UPDATED: April 23, 2019
We strongly recommend that you execute the following steps to resolve the issue if you are using the impacted versions to resolve this important product issue:
  • Microsoft SQL Database Users: Run usp_s_purge_domain_workitems_MS_SQL.sql
  • Oracle Database Users: Run usp_s_purge_domain_workitems_Oracle.sql
  • Upgrade to EngageOne Server v4.4 SP7 or EngageOne Server v4.4 SP8 where the issue has been permanently resolved

To obtain the SQL script, please reach out to your local support team (software.support@pb.com).