VERIFIED SOLUTION i

EngageOne Generate terminating with a GEN9999D error

Product Feature: Batch (Non-Accumulated)

 

Issue

When running non-accumulated batch in EngageOne® Generate, the process is occasionally terminating with a GEN9999D error.

Cause

This is a generic error message which can be caused by numerous factors.

Resolution

UPDATED: May 23, 2019
Check the batch log (found in EngageOne_install_path\batch\bin) which may provide further details, for example about invalid variable data being passed, or unset variables.  This log file may also give the location of the incident archive folder, which will contain it's own log file.

If these log files do not provide sufficient information to determine the reason for the failure, please contact technical support (software.support@pb.com).