VERIFIED SOLUTION i

Error 'Failed to update delivery item. USER is not authorized to access work item 00000' in EngageOne 4.4.8 or older

EngageOne 4.4.8

Issue

In EngageOne 4.4.8 or older, the following error is seen in the eo-soap-services.log or in SOAP UI when trying to update a delivery item using the updateDeliveryItem web service:

Error:
Failed to update delivery item. <user_id> is not authorized to access work item <work_item_id>

Cause

In this case, the error occurred because the updateDeliveryItem web request was submitted with a user that had a different capitalization than the user that created the work item:

<com:userId>user</com:userId>

vs


<com:userId>USER</com:userId>

Resolution

UPDATED: July 16, 2019
The following can help solve this issue:

1. Use lower case for the userid

or

2. Upgrade to 4.4.9 where this defect has been fixed.