VERIFIED SOLUTION i

Error 'Failed to search for work items' when searching for work items with status 'New' in EngageOne 4.4.x

EngageOne 4.4.8

Issue

In EngageOne 4.4.8 or older, the following error occurs when using the searchWorkItem web request to search for work items with status 'NEW':

Failed to search for work items

Cause

This is a known bug in EngageOne 4.4.8 or older, which causes internal errors if any of the items included in the list returned in searchWorkItems SOAP web service call has a status NEW (13).

Resolution

UPDATED: July 16, 2019
To fix this issue, please upgrade to EngageOne 4.4.9