VERIFIED SOLUTION i

"Technical Difficulty, please contact your administrator" in EngageOne Administration


 

Issue

User is not able to login to EngageOne Administration.

While launching EngageOne Administration login page, message "Technical Difficulty, please contact your administrator" is thrown.
Refer following screenshot:
User-added image

Entry in the Application Server log:
Caused by: com.microsoft.sqlserver.jdbc.SQLServerException: The TCP/IP connection to the host <hostname>, port <port no> has failed. Error: "Connection refused: connect. Verify the connection properties.
Make sure that an instance of SQL Server is running on the host and accepting TCP/IP connections at the port. Make sure that TCP connections to the port are not blocked by a firewall."

 

Cause

The error message indicates EngageOne Application not being able to connect to repository on which EngageOne database is hosted.

Resolution

UPDATED: March 27, 2017
In case EngageOne is hosted on SQL Server:
  • Ensure that instance of SQL Server is running on the specified host.
  • It is accepting TCP/IP connections at the specified port.
  • TCP connections to the port are not blocked by a firewall.

Connection settings (SQL instance, port etc) can be known from log created during EngageOne installation. To know the connection settings, refer to section
#Enter Database Configuration of 'EngageOne_InstallLog.log' file created in EngageOne home directory.

In case issue still remains unresolved, contact technical support.