VERIFIED SOLUTION i
X

How to resolve frequent login prompts when using a Spectrum cluster

Issue

When Spectrum™ Technology Platform is configured to run in a cluster, Management Console and Enterprise Designer will prompt for user credentials after every action, even though the user is already logged in.

Cause

This is a known issue with Spectrum™ Technology Platform 11.0 SP1.  When running in a cluster and Management Console or Enterprise Designer are connected through the load balancer, the Spectrum™ Technology Platform server is using the host information as part of its security token.

Resolution

UPDATED: March 30, 2017


Follow steps to configure the Spectrum™ Technology Platform server to exclude the host information from its security token.
  1. Edit the <Spectrum-Install-Directory>/server/app/conf/spectrum-container.properties file.
  2. Set the value of the spectrum.security.authentication.token.remoteClientCheck.enabled property to false.
    spectrum.security.authentication.token.remoteClientCheck.enabled=false
  3. Install the Spectrum™ Technology Platform 11.0 SP1 S10 patch.  This corrects an issue where the software continues to use the host information in the security token after the spectrum.security.authentication.token.remoteClientCheck.enabled property is set to false.
  4. Restart the Spectrum™ Technology Platform server process.

Environment Details

Products Affected:  Spectrum Technology Platform
Product Feature: Spectrum Server
Operating System: Windows, Linux, AIX, Solaris, HP-UX, Red Hat

 

Downloads

  • No Downloads