VERIFIED SOLUTION i

EngageOne Video EOV background audio on interaction cards does not play on mobile devices


 

Issue

Music files behind an interaction card works fine on laptop but it doesn’t get played on mobile devices.

Cause

Background audio (music) on interaction cards is not supported on mobile, this is a known limitation of the platform that is documented in the release notes.

The "Video Delivery", "Device types" table says the following in Audio row for mobile platforms:
"No background audio on interactions and, for each state, only the first audio track is rendered." 

Resolution

UPDATED: April 18, 2017
Please look into adding background music as audio clip in subscenes in your project.
For example, background or incidental music.

You can select an audio clip from the Media Library and right click‘ Master Audio Track’ .
This automatically triggers this audio clip to play at the start of any video sequence, unless overridden by manually adding an alternative audio clip in a
subscene.

An audio clip which is added to a subscene must either be the first item in the subscene or the ‘Clip Usage Limit’ must be increased to allow the audio track to be
included.
The audio clip can be added to it’s own subscene but you must make sure that the ’SubScenes Usage Limit’ is configured to allow multiple subscenes to be included if the scene contains multiple subscenes which should be included.

You will need to prepare appropriate background audio tracks in advance of using the Editor.
For example you will need to consider the audio levels for all your background audio tracks, and how it will integrate with the ‘built in’ audio of your video clips.

The Editor is not designed to adjust the volume levels of individual audio or video files.
This will need to be performed using your preferred linear video editor or audio editing software.

As with video, you may find that working with background audio tracks is an iterative process, and that you need to test the audio in Preview page.

Please verify and contact us at software.support@pb.com if you have any query.