VERIFIED SOLUTION i

Mail360 Data Manager 3.1 not working with TLS 1.2

MAIL360 Data Manager™ 3.1, and similar versions

Issue

FYI- Transport Layer Security (TLS) and its predecessor, Secure Sockets Layer (SSL), both frequently referred to as "SSL", are cryptographic protocols that provide communications security over a computer network.

For Security reasons at their site, a customer needed to use only TLS version 1.2, nothing with a lower version number.  When they tried, they were no longer able to access the MAIL360 Data Manager™ User Interfaces.  
The error was similar to-
"underlying connection was closed: An unexpected error occurred"

Cause

Changes needed in two MAIL360 Data Manager™ config files

Resolution

UPDATED: May 14, 2019
Had the user make the following changes-
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Configuration for identity Manager UI - 

1. Navigate to <mail360DM install>\Group1\MAIL360 Identity Server Web Client\Identity Server Web 
2. Take the backup of Web.config and open it in a text editor. 
3. Search for '<system.web>' 
4. Copy '<httpRuntime targetFramework="4.6.1" />' and paste it above <compilation debug="true" targetFramework="4.6.1"> 
5. Save the file 
6. Reset IIS. 


Configuration for Data Manager UI - 

1. Navigate to <mail360DM install>\Group1\MAIL360 Data Manager Web Client\DataManagerWeb 
2. Take the backup of Web.config and open it in a text editor. 
3. Search for '<system.web>' 
4. Edit '<httpRuntime targetFramework="4.5"/>' to <httpRuntime targetFramework="4.6.1"/> 
5. Save the file 
6. Reset IIS. 

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The customer replied that it corrected the issue
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This worked! We made the suggested changes, disabled TLS 1.0 and TLS 1.1 and can now successfully login to both user interfaces.
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