VERIFIED SOLUTION i

Portrait Dialogue: Unable to set dialog execution chunk completed status

Issue

Execution of an operation fails due to error "Unable to set dialog execution chunk completed status (doec_id=*****)"

User-added image

Cause

The error occurs when there are a lot of concurrent threads running in Portrait and it is possible that two threads will try to execute the same execution chunk.
This can occur in one-application-server environment but is more probable in a multi-server environment.

In most instances when two threads try to execute the same execution chunk, one of them will fail, so there won't be any negative impact on the result of the campaign apart from the error recorded in the log file. However, under some circumstances, it can happen that two threads succeed and it can result in a specific action executed twice. For example, the same email can be sent twice to the customer.

Resolution

UPDATED: April 21, 2017
This has been identified as a defect in Portrait Dialogue v6.1.x and hotfix (Hotfix 3 (6.1.0.349)) is available to resolve the issue. This hotfix is intended to correct many other problems and might need additional testing. 
The Readme file of the Hotfix is attached with this knowledge article.

To download the complete Hotfix, Contact Pitney Bowes Software Support.