VERIFIED SOLUTION i

Resolve status in EngageOne deliver Document for channels other than email and fax showing as processing

Product Feature: Web services

Issue

Changes to deliverDocument to address issues in the email and fax channels have changed the status of other deliverDocument channels (for example Immediate).  This now shows as processing even when the channel status is set to composed (see extract from SOAP response below):

<deliveryRequest>
<ns4:id>1066</ns4:id>
<ns4:status>PROCESSING</ns4:status>
<ns4:deliveryItems>
<ns4:deliveryItem>
<ns4:id>10054</ns4:id>
<ns4:deliveryChannel>
<ns4:id>1014</ns4:id>
<ns4:name>PDF-Immediate</ns4:name>
<ns4:mode>IMMEDIATE</ns4:mode>
<ns4:type>PRINT</ns4:type>
<ns4:device>
<ns4:id>1009</ns4:id>
<ns4:name>PDF-Immediate</ns4:name>
<ns4:type>PDF</ns4:type>
<ns4:preview>false</ns4:preview>
<ns4:HIPId>0</ns4:HIPId>
<ns4:metaId>0</ns4:metaId>
</ns4:device>
</ns4:deliveryChannel>
<ns4:status>COMPOSED</ns4:status>

The result of this is that when purge is run, because the status in the database is PROCESSING the item is not removed.
 

Cause

Fix applied for the email and fax channels incorrectly changed the request status for all other delivery channel types to PROCESSING.

Resolution

UPDATED: August 3, 2017
Fixed in version 4.4, and all versions of 3.1.2 later than build 102.