VERIFIED SOLUTION i

Resolve user details not getting saved when user name contains an apostrophe in EngageOne 4.4

Product Feature: Deployment / Configuration
Versions affected: EngageOne V4.4 GA and 4.4 SP1

 

Issue

When an attempt is made to add a user, the UI accepts the user being assigned to the role – but doesn’t save the change. The UI reports the user has been added but exiting the role assignment page and entering the page again, the user you have just added is not visible. This issue also affects other areas, for example Workflow.

Cause

Users name contains an apostrophe, for example, Gilbert O'Sullivan.

Resolution

UPDATED: September 28, 2017

Resolved in builds of later than EngageOne 4.4.2.493 (4.4 SP2 and onwards)