VERIFIED SOLUTION i

Resolve error 'An error has occurred. If this problem persists, please contact support' occurred in EngageOne Content Author

Products Affected: Content Author

Issue

When clicking the 'Apply' button in the Content Author Configuration Manager, following error occurs 'An error has occurred.  If this problem persists, please contact support'.

Cause

This could be caused due to Content Author Configuration Manager not being launched using elevated privileges.

Resolution

UPDATED: July 7, 2017
Use elevated privileges (i.e "Run as Administrator") to launch the Content Author Configuration Manager instead of using double-click.