VERIFIED SOLUTION i

Resolve "Weight is negative" on the DM300C, DM400C, DM450C, and DM475

Products affected: DM300c™, DM400c™, DM450c™, DM475™

Issue

The meter says "Weight is negative" and will not weigh mail.

Cause

The scale was not properly zeroed.

Resolution

UPDATED: May 21, 2018
Zero the scale.
  1. Remove any items that are on the scale.
  2. Press Zero the scale.
  3. If you still have weighing issues, follow these steps for a safe reboot:
    1. Unplug the power cord.
    2. Wait one to three minutes.
    3. Remove the scale from the top of the meter.
    4. Turn the scale upside down and verify that the scale pins are not bent.
    5. Remove the four rubber pads from the bottom of the scale.
    6. Return the scale to the top of the meter.
    7. Plug the power cord back in, ensuring that it is plugged directly into a wall outlet.
If your issue is not resolved, contact technical support. Please have your model and serial number ready.