VERIFIED SOLUTION i

How to resolve EngageOne Content Author web client not saving message after editing

Products Affected: EngageOne Content Author
Product Feature: Installation / Upgrade
Operating System: Windows
 

Issue

When using the EngageOne Content Author web client to edit a message, the following error occurs when saving the message:

User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; WOW64; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; .NET4.0C; .NET4.0E)
Timestamp: Wed, 9 Aug 2017 19:35:34 UTC


Message: Syntax error
Line: 3
Char: 1
Code: 0
URI: http://localhost/CCMContentAuthor/MessageProperties/Author/AuthorActions.asmx/js


Message: 'AuthorActions' is undefined
Line: 69
Char: 13
Code: 0
URI: http://localhost/CCMContentAuthor/MessageProperties/scripts/Editor.js?version=2

Webpage error details

User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; WOW64; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; .NET4.0C; .NET4.0E)
Timestamp: Wed, 9 Aug 2017 19:39:54 UTC


Message: Syntax error
Line: 3
Char: 1
Code: 0
URI: http://localhost/CCMContentAuthor/MessageProperties/Author/AuthorActions.asmx/js


Message: 'AuthorActions' is undefined
Line: 6
Char: 9
Code: 0
URI: http://localhost/CCMContentAuthor/MessageProperties/scripts/MessageActions.js

 

Cause

The EngageOne Content Author Release Notes has step-by-step instructions on how to do the installation.  The cause for the error is due to the IIS being installed after .NET and the ASP not being registered with IIS.  Please see "Resolution" on how to resolve this.

Resolution

UPDATED: August 14, 2017
Issues with IIS
• If Microsoft IIS is installed after Microsoft .NET Framework 4.0 has already been installed
then ASP (a component of .NET) must be registered with IIS. To do this, run:
C:\WINDOWS\Microsoft.NET\Framework\v4.0.30319\aspnet_regiis.exe /i
• Content Author now uses Microsoft .NET Framework 4.0 and you must configure your
Microsoft IIS settings to access it correctly before running Content Author:–
– if you are upgrading to this release from Content Author 6.0 or earlier,
– or you already have an earlier version of Microsoft .NET Framework.