VERIFIED SOLUTION i

"Give root password for login" message on the Connect+ series and SendPro P series

Products affected: Connect+® 500W, Connect+® 1000, Connect+® 2000, Connect+® 3000, SendPro® P1000, SendPro® P1500, SendPro® P2000, SendPro® P3000

Issue

The Connect+® / SendPro™ P Series asks for the root password and will not boot up.

Cause

The internal meter software has malfunctioned.

Resolution

UPDATED: March 13, 2019
A reboot may resolve the issue:
  1. Press and hold the blue power button until the display turns off.
  2. After the meter has been off for 10 seconds, press the power button to power back up.