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Resolve Win Error: 10061 Connection refused in Sagent

Issue

WinError: 10061 Connection refused in Sagent Data Flow.

Cause

There could be multiple cause of the issue. The user identify the component such as Sagent Automation/Web Service etc. which is throwing this error and enable relevant logs for further analysis.

Resolution

UPDATED: November 15, 2017


Sagent web service:
Check for AgentMachine and Port number in Sagent registry under following path: 
HKLM\Software\Sagent\DataMart\WS 

AgentMachine should point to the machine running Sagent web service and Port number is the port for Sagent web service which is 18083 by default. 
Sagent Automation:
  • Make sure that the folder structure is same as in the Design Studio.
  • verify if the port number is correct.
  • verify if the Dataflow server is up and running
  • verify Automation services from Local host
.
There could be more reasons for this error like user permissions etc.
If the issue still remains, enable Sagent logs and send to Software Support for investigation:
Enable following logs:
  • SAPPCOM logs
  • Web Service logs
Refer sainlge utility guide to enable the logging.
 

Environment Details

Product Feature: WebService


 

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