VERIFIED SOLUTION i

Resolving 'https' is invalid; expected 'http' error in Portrait Dialogue

Issue

When opening a Dialogue connected to an HQ Campaign in Portrait Dialogue™ solution (PD), the following error message appears.
"The provided URI scheme 'https' is invalid; expected 'http' 

Cause

 The reason for this is that the Portrait Shared Server (PSS) services are set to using HTTPS, and the Windows Communication Foundation (WCF) settings in the CmsPlugin.dll.config file are not compatible with that configuration.

Resolution

UPDATED: May 2, 2017
If this is happening then you have to make modifications to the CmsPlugin.dll.config file.
  • Goto the CMS Plugin Folder
    • PST\Million Handshakes\Dialog Server\DialogServerPlugins\Cms
  • Edit CmsPlugin.dll.config
  • Change all security mode entries from None to Transport for all items.  There should be at least four of them.
  • Here is an example :
    • <security mode="None">
          <transport clientCredentialType="None" proxyCredentialType="None" realm=""/>
          <message clientCredentialType="UserName" algorithmSuite="Default"/>
      </security>
    • <security mode="Transport">
          <transport clientCredentialType="None" proxyCredentialType="None" realm=""/>
          <message clientCredentialType="UserName" algorithmSuite="Default"/>
      </security>