VERIFIED SOLUTION i
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Exponare: Blank screen displayed after log in to Exponare Enquiry

Issue

The blank screen is displayed after login to Exponare Enquiry.

The following error may be recorded in the Windows Event log:
Log Name: Application
Source: ExponareEnquiry
Date: 10/04/2013 4:54:11 PM
Event ID: 3102
Task Category: None
Level: Warning
Keywords: Classic
User: N/A
Computer: xxx
Description:
Unable to Update file QATSettings.xml.
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
<System>
<Provider Name="ExponareEnquiry" />
<EventID Qualifiers="0">3102</EventID>
<Level>3</Level>
<Task>0</Task>
<Keywords>0x80000000000000</Keywords>
<TimeCreated SystemTime="2013-04-10T06:54:11.000Z" />
<EventRecordID>2775726</EventRecordID>
<Channel>Application</Channel>
<Computer>xxx</Computer>
<Security />
</System>
<EventData>
<Data>Unable to Update file QATSettings.xml.</Data>
</EventData>
</Event>

 

Cause

This could be due to the following reasons:

1. QATSettings.xml file being corrupted or Users do not have access to %appdata%\MapInfo\Exponare folder
Upon exiting Exponare Enquiry window, QATSettings.xml file gets updated with the command available in the quick access toolbar. After log in to Exponare Enquiry, the application tries to access this file to read the QAT commands available to create the User Interface for that particular user.
The abrupt closing of Exponare Enquiry window could lead to the corruption of QATSettings.xml file. Therefore, after logging into Exponare Enquiry, a black screen is returned as it is unable to read the QATSettings.xml file to create the user interface.

2. Work-context group has not been assigned to the user logging in
This can happen in new configurations. If the step of assigning a work-context group to the user has been missed, there is no data to display for that user once logged into Enquiry.

Resolution

UPDATED: March 30, 2017


To solve the issue, please perform one of the followings:

1. Delete QATSettings.xml file (default QAT will be displayed to all users) or manually update the data in correct XML format in QATSettings.xml. If access permission to the file is the reason, provide access to %appdata%\MapInfo\Exponare folder. QATSettings.xml file is located in the %appdata%\MapInfo\Exponare folder.

2. Assign work-context groups to Users via Configuration Manager.

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