VERIFIED SOLUTION i
X

Resolve E2 Vault missing marketing images in some of the invoices

Issue


Customer publication did not contain mareketing images.These images were coming from HIM files of content author.


The only thing they changed is to redirect resources from C drive to SAN S drive.


Error message in Render logs
 
e2renderd.20140526.000003.8040.log:11:39:23 10.90.66.74:2538 <render1> ERROR 70801: unable to find resource [S1M000CI] in resource set [sh_invoices]

e2renderd.20140526.000003.8040.log:11:39:24 10.90.66.74:2546 <render1> ERROR 70801: unable to find resource [S1M000C2] in resource set [sh_invoices]

e2renderd.20140526.000003.8040.log:11:39:24 10.90.66.74:2546 <render1> ERROR 70801: unable to find resource [S1M000BY] in resource set [sh_invoices]

e2renderd.20140526.000003.8040.log:11:39:28 10.90.66.74:2575 <render1> ERROR 70801: unable to find resource [S1M000CE] in resource set [sh_invoices]

e2renderd.20140526.000003.8040.log:11:39:28 10.90.66.74:2575 <render1> ERROR 70801: unable to find resource [S1M000CI] in resource set [sh_invoices]

e2renderd.20140526.000003.8040.log:11:39:29 10.90.66.74:2582 <render1> ERROR 70801: unable to find resource [S1M000CE] in resource set [sh_invoices]

e2renderd.20140526.000003.8040.log:11:39:29 10.90.66.74:2582 <render1> ERROR 70801: unable to find resource [S1M000CI] in resource set [sh_invoices]


 

Cause

For some invoices, the marketing images are not appearing, but in hardcopy AFP/PDF file, it was there.

So the issue was with Document rendering.

This indicates image resources were not available to server.

Resolution

UPDATED: August 24, 2017


RCA and Solution Provided to customer

 
RCA

The server.ini file has the following line:
{noformat}
;DistributionPath=S:\E2\Distrib
{noformat}

As this line is commented out, the server is looking for resources under its current directory. For example:
{noformat}
D:\Program Files\Group1\e2\Vault\Server\distrib\sh_invoices\S1M000CA
{noformat}

However, the profile is extracting inline resources to S:
{noformat}
[sh_invoices]
ExtractResources=S:\E2\DISTRIB\sh_invoices\
{noformat}

Currently, newly extracted resources are going to one directory and the resources are being read from another. So, the newly extracted resources will not be available for rendering.

Solution

We would suggest you to try uncommenting the DistributionPath line in the server.ini file and restart. That way the server should see the newly extracted files.

However, you need to make sure that any resources that exist only in Server\distrib, if any, get copied to S:\E2\DISTRIB. (That is, old resources may only exist in Server\distrib so we need to merge the new and old resources together into one location.)

 

Environment Details


 

Downloads

  • No Downloads