VERIFIED SOLUTION i
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Resolve upgrade issue from BPA 904 to BPA 905

Issue

Automation upgrade issue from BPA 904 - BPA 905.

Cause

How to upgrade from BPA version 904 to BPA version 905. First uninstall and do not select anything on this screen. Click on the “Remove “ button at the bottom of the screen. When installing select “ Advanced Setup” and this screen will be shown. Everything is by default selected on the server, just click “Next”, then “USE existing BPA server 9 configuration”.

The user can select “Default values”, but can also select customised values if you’ve previously made changes to the Ports of the various things, changed the AGENT name, or changed the user-id and password.

The question is how do you upgrade a deployed agent, or client development tools on remote clients / agents. Do an uninstall on the client machine and then the install the development tools again from the 905 install media using advance options? What about remote agents? 

Resolution

UPDATED: November 27, 2017


Take backup of the database before upgrading. If you have installed with SQL Express, you can go into the SQL Server folder in Program Files/Program Files (x86) and make a copy of the database files. 

Upgrade Process: 
  1. Uninstall BPA from Add/Remove Programs (Do not add check for any of the check boxes when prompted ? Select Next. 
  2. Make sure the AutoMate BPA Server 9 folder under program files C:\Program Files or C:\Program Files (x86) has been removed 
  3. Install Version 9.0.5.4 
  4. During install choose Advanced Setup and select "Use existing configuration," You will need to connect to your existing data base. 
  5. You will need to uninstall and upgrade all other components Like your remote agents or development tools. If you have deployed the agents from the SMC there is no need to upgrade or install anything on the agent machine.

Environment Details

Product Feature: Installation / Upgrade

 

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