VERIFIED SOLUTION i

Resolve issue where the TXT file for SMS messages are delivered in an incorrect way in EngageOne Digital Delivery

Product Feature: Administration

Operating System: Windows 2008 64bit

Database: MS SQL

Configuration: Apache TomCat
 

Issue

When the customer received the test SMS messages he processed via eMessaging, they would look like this on the handset:

Message for: MSISDN
Unicode:0
Text:Message text message text message text.

Cause

The customer developed a publication for SMS messages through EngageOne Designer and had made their publication such that it had the following structure:

Message for:MSISDN
Unicode:{0|1}
Text:{message text message text message text}
Message for:MSISDN
Unicode:{0|1}
Text:{message text message text message text}

Resolution

UPDATED: November 2, 2017
The publication actually needed to be set up to that the field identifiers were all lowercase, except for the "Message for" field, like this:

Message for:MSISDN
unicode:{0|1}
text:{message text message text message text}
Message for:MSISDN
unicode:{0|1}
text:{message text message text message text}