VERIFIED SOLUTION i

Resolve issue where batch option -quiet doesn't suppress output to console on AIX for EngageOne Server

Product Feature: Batch (Non-Accumulated)

Operating System: AIX

Issue

During the batch execution on AIX, to reduce the amount of the text that’s written to console, User has used “-quiet” as shown in the below mentioned command line.

However, it is not working.

./run-na-batch.sh -domain $DOMAIN_NAME -template "$TEMPLATE_NAME" -deliveryOption $DELIVERY_OPTION -dir "$TEMPLATE_INPUT_DIR" –quiet

Host Operating System is AIX, version 6.1.

Cause

com.ibm.ws.webservices.thinclient_6.1.0.jar is used for WebSphere 6.1 and com.ibm.ws.ejb.thinclient_7.0.0.jar is used for WebSphere 7.0.

As per the log the customer is using WebSphere 7.0 and com.ibm.ws.ejb.thinclient_7.0.0.jar is in the <EngageOne_Install_Folder>/server/batch/lib folder already.

It appears putting those two jar files in the batch class path would cause this issue.

Resolution

UPDATED: November 14, 2017
1. The batch process would load all the jar files under the <EngageOne_Install_Folder>/server/batch/lib folder. Renaming jar files won't work.
2. *REMOVE* the com.ibm.ws.webservices.thinclient_6.1.0.jar file from the <EngageOne_Install_Folder>/server/batch/lib folder.
3. The batch process needs com.ibm.ws.ejb.thinclient_7.0.0.jar. Just leave it as it is and do not rename it.
4. The customer doesn't need to restart the application server.