VERIFIED SOLUTION i

Resolve error 'The underlying connection was closed' in EngageOne Delivery Audit

Issue

After installation of EngageOne Delivery Data Manager web (User Interface), an error 'The underlying connection was closed' is encountered while logging into the Data Manager web URL.
 
The_underlying_connection_was_closed_error.png

Cause

This could be observed due to either of following:
  • Certificates have been expired
  • Certificate are not bound with the ports on which various EngageOne Delivery Audit Services runs.

Resolution

UPDATED: November 21, 2017
  • If the certificates are expired, then the customer needs to get new certificates from a third party. 'makecert' command can be used to generate the self-signed certificates.
  • If certificates are not bound with the port(s), then following commands can be used for binding a port with the certificates.
Netsh.exe http add sslcert ipport=0.0.0.0:8884 appid={00000000-0000-0000-0000-000000000000} certhash=thumbprint.
Replace thumbprint with certificate's thumbprint. Above command (after replacing thumbprint) should be run four times with various ports on which EngageOne Delivery Audit Services are run.

For detailed information, refer section 'Data Manager UI Issues' in EngageOne Delivery Audit Install Admin Guide shipped with the product documentation.