VERIFIED SOLUTION i

How to overcome an exception when we you are trying to create a work item using the Engageone Interactive

Product Feature: Installation / Upgrade
 

Issue

Engagageone approval service is throwing the below exception when we are trying to create a work item using the Engageone Interactive.

Caused by: com.g1.ocm.api.ApprovalException: 
at com.g1.ocm.ws.ApprovalSvcImpl.deliverDocumentByToken(ApprovalSvcImpl.java:229) 
at com.g1.ocm.ws.ApprovalSvcImpl.submitWorkItem(ApprovalSvcImpl.java:90) 
at com.g1.ocm.ws.ApprovalSvcImpl.createAndSubmitWorkItem(ApprovalSvcImpl.java:49) 
... 49 more 
com.pb.engageone.server.tds.framework.server.ejb._ServerControllerRemote_Stub.doServerAction(_ServerControllerRemote_Stub.java) 
at com.pb.engageone.server.tds.framework.server.ServerDelegate.doServerAction(Unknown Source) 
at com.pb.engageone.server.tds.api.DeliveryApi.deliverDocument(Unknown Source) 
at Caused by: javax.ejb.EJBTransactionRolledbackException: 
at com.ibm.ejs.csi.TranStrategy.commit(TranStrategy.java:988) 
at com.ibm.ejs.csi.TranStrategy.postInvoke(TranStrategy.java:259) 
at com.ibm.ejs.csi.TransactionControlImpl.postInvoke(TransactionControlImpl.java:570) 
at com.ibm.ejs.container.EJSContainer.postInvoke(EJSContainer.java:4558) 
at com.pb.engageone.server.tds.framework.server.ejb.EJSRemote0SLServerControllerBean_5cebf04f.doServerAction(EJSRemote0SLServerControllerBean_5cebf04f.java)
at com.pb.engageone.server.tds.core.delivery.DocumentDeliveryImpl.deliverDocument(Unknown Source) 
at com.g1.ocm.api.DeliveryService.deliverAction(Unknown Source) 
at com.g1.ocm.api.DeliveryService.deliverDocumentByToken(Unknown Source) 
at com.g1.ocm.api.OcmDeliveryAgent.deliverDocumentByToken(Unknown Source) 
at com.g1.ocm.ws.ApprovalSvcImpl.deliverDocumentByToken(ApprovalSvcImpl.java:225) 
 

Cause


1) WTRN0063E: An illegal attempt to commit a one phase capable resource with existing two phase capable resources has occurred. 
 2) Also today we are seeing the below workflow exception during the approval process. Can you explain in what scenario this exception is encountered? 


[10/28/14 16:33:39:905 SGT] 0000003c ApproveDocume E com.pb.eventmonitor.event.sink.log.EventMonitorLogSink handleEvents ApproveDocumentEvent[name=Approve document,eventType=Error,processType=approve.document,userId=A5115012,externalId=22,externalSource=EngageOne,comments=,startTimestamp=10/28/14 4:33 PM,endTimestamp=10/28/14 4:33 PM,workflowName=null,workflowEventName=null,properties=[Pair[key=work.item.status,value=5],Pair[key=server,value=CWECMAPOS0A.OCBCGROUP.OCBC.COM],Pair[key=domain.name,value=I.PUBLISHING_Domain],Pair[key=exception.message,value=WorkflowException],Pair[key=exception.stack,value=com.g1.ocm.ws.approval.WorkflowException: WorkflowException 
at java.lang.J9VMInternals.newInstanceImpl(Native Method)


• The template which we were using earlier do not have any workflow tagged to it. After tagging a workflow to the template, the earlier exception which we were seeing is gone. But , the workitem should be created even if no Workflow is tagged to the particular template. Could you please check this thing in EO. 
• We are able to create and approve a workitem with delivery option as BATCH. 
• However, after this when we tried to execute the batch manually, It was not able to process the workitem. 
• It was also not creating any files(metrics.xml, answer.xml,print.onh,contentprops.xml) in the tds\delivery\ folder after approval of workitem. In ideal scenario these files should be created in this folde

Resolution

UPDATED: April 21, 2017
Customer clarified that these issues are from beginning,And occuring for all templates. 

Logs analysis suggest some installation steps when not configured /followed properly can lead to such errors. 

As we discussed with our expert too, the issues being faced can be due to steps on : 

1)where we update the class load order point #2 of page 84(see attached guide) 

2) followed point #3 at page 100. or not 

We need to be sure if steps in Guide were followed completely. 

Re installation giving special attention to above mentioned pages and following guide should resolve the issue, 

Customer confirmed :
This is resolved. com.ibm.ws.webcontainer.invokefilterscompatibility was not set in Websphere that caused the issue

The following is from the EngageOne Installation Guide.  This step may have been missed during the installation which can cause the error.
Add two server scope properties:
com.ibm.ws.webcontainer.invokefilterscompatibility = true
Set Heuristic completion direction to COMMIT and select the Accept heuristic hazard check
box in Application servers > Server_Name > Container Services> Transaction service.


This article helps explain the issue:
https://www.ibm.com/developerworks/community/blogs/aimsupport/entry/trace_analysis_wtrn0063e?lang=en