VERIFIED SOLUTION i

Zero KB output produced by Generate, batch or web service execution in EngageOne

Issue

Output produced by Doc1Gen, EngageOne batch or web service is zero KB in size upon choosing PDF as output device.

Cause

Possible causes include:
  • Input file provided does not lead to output creation. In this scenario error encountered in the EngageOne Generate will log  "GEN0075A no publications were triggered from the input data error" on the console, batch or Application Server log.
  • Document in EngageOne designer does not include output device selected. 
  • Due to known defect which is fixed in the latest version of EngageOne Generate.

Resolution

UPDATED: May 23, 2017
  • Input file provided does lead to output creation. Try to regenerate the HIP by selecting other output device like PS or AFPDS and verify if they are generated with valid size. If no output is generated then there is a need to match the input file data and logic in Designer.
  • Document should have corresponding output device selected so in Designer, PDF or required output device should be enabled for document which is expected to be produced. This needs to be chosen at document properties in document->properties->'Support Output Devices'. Refer below screenshot.
  • If above condition are satisfied and issue still exists, use latest EngageOne Generate. There has been defect fixed around zero KB PDF production in latest EngageOne Generate. To upgrade the EngageOne generate used in EngageOne, follow upgrading EngageOne generate.
In case issue remains unresolved, contact Client Support.