VERIFIED SOLUTION i

Resolve scale not weighing or no scale line on the DM100i-DM225

Products affected: DM100®i, DM125™, DM200L™ DM225™

Issue

Your scale does not weigh and your scale line on the display is missing, or the number is missing for the pounds and ounces.

Cause

  • Your meter does not communicate with your scale, or
  • Your scale is defective.

Resolution

UPDATED: March 28, 2019
There are two ways to troubleshoot this issue; try them in this order:
  1. Zero your scale
  2. Reboot your meter

Solution 1: Zero your scale:
  1. Select SCALE.
  2. Select Zero the scale.
 See Zeroing your scale for more help with zeroing issues.

Solution 2: Reboot your meter:
  1. Lift your scale off of your meter.
  2. Unplug your power cord.
  3. Wait three minutes. During this time: 
    1. Turn your scale upside down 
    2. Verify that your scale pins are not bent, and
    3. Remove the 4 rubber pads from the bottom of your scale
  4. Plug your meter back in, and place your scale back on top of your meter.