VERIFIED SOLUTION i

Resolve blinking lights on the DM100i, DM125, DM200L and DM225

Products affected: DM100®i, DM125™, DM200L™, DM225™

Issue

The Page Up, Page Down, and power lights are blinking and the meter will not turn on.

Cause

An internal component has failed.

Resolution

UPDATED: May 2, 2018
You may be able to clear the error by restarting the meter. Follow these steps to restart safely:
  1. Unplug the power cord.
  2. Wait one to three minutes.
  3. Plug the power cord back in, ensuring that it is plugged directly into a wall outlet.
If the issue is not resolved after restarting the meter, contact customer support from 8 am to 8 pm Eastern Time. Please have your model number ready.