VERIFIED SOLUTION i

Resolve "Negative Weight Error" on the DM500, DM525 and more

Products affected: DM500™, DM525™, DM550™, DM575™, DM800™, DM800i™, DM825™, DM875™, DM900™, DM925™, DM1000™, DM1100™

Issue

After removing an item from the scale, the displays "Negative Weight Error".

Cause

Possible reasons for Negative Weight Errors:
  • The scale was bumped or moved.
  • Load cells were disrupted when an awkward or heavy item was placed on the scale.
  • Large envelopes or packages placed on the scale are touching an object near the scale.
  • Zero Scale was selected when an item was still on the scale.
  • A fan or air vent is blowing on the scale.

Resolution

UPDATED: May 7, 2018
To clear the error:
  1. Remove all items from the scale.
  2. Press Menu.
  3. Select Zero Scale.
If the message persists, restart the meter. Follow these steps to restart safely:
  1. Turn the power off with the power switch.
  2. Wait for the display to turn off.
  3. Wait one to three minutes.
  4. Turn the power switch back on.
If the issue is still not resolved, contact client support. Please have your model number ready.