VERIFIED SOLUTION i

Resolve the warning 'Payment status set in System Defaults must be Committable and Outstanding' when committing Payment Requests in Confirm

Products affected: Confirm®

Issue

When trying to commit the Payment Request from the Payment Batch screen in Confirm® the payments do not commit due to the Job Status preventing commit (in Payment Batch), even though the Job Status in question is ticked to enable payment.

When trying to commit the payment on the Payment Batch screen, users get the below validation:
"Payment status set in System Defaults must be Committable and Outstanding. You may view the report but not commit." 
 

Cause

The reason why the Payment is not committed is related to the Payment Status set at System Defaults in Confirm Client.

Resolution

UPDATED: August 7, 2018
The Job Status for Payment Commit should have checked the Commit and Outstanding check box.

Navigate to Main > Maintenance Management > Contractor Management Lookups. Open Contract Management System Settings and find the Job Status that is used in the Payment Committed field.  Open the Job Status screen for this Status.  To commit payments tick the Outstanding check box as well as the Commit one.  Log out of Confirm and log in again to commit the payment.