VERIFIED SOLUTION i

Confirm - Street Works Immediate Notice Served with a start time of "00:00:00"

Product Feature: Street Works

Operating System: Windows 2003
 

Issue

Street works Immediate notice submitted with a start time of "00:00:00". This resulted in the client receiving an FPN.

 

Cause

On entering the Immediate notice the start time is entered as 00:00:00 on the Confirm screen, this should then be updated accordingly.

If the start time is not changed then there would have been a 'Notice is Late' warning while creating this Notice. If this warning is ignored and the time is not changed then the notice will have a valid start time of "00:00:00":

<StartTime> is a "time" field, which the EToN Spec states: 

Time - hh:mm:ss - The 24-hour clock format is used where hh = hour, mm = minute and ss = seconds. Optional fractional seconds component is not used. A time of 00:00:00 denotes the start of a new day. 

Therefore sending 00:00:00 for <StartTime> in the XML is fine, and we should not prevent users from specifying that time on the Wizard or in the XML. 

Resolution

UPDATED: April 6, 2017
When the 'Notice is late' warning is issued, update the start time to the correct time. If it is left then the start time will be sent as :00:00:00", which is valid.