VERIFIED SOLUTION i

Resolve issue where e-Messaging failed to count messages which have received Out of Office replies in EngageOne Digital Delivery

Product Feature: Background Processes
 

Issue

e-Messaging does receive an Out of Office reply for a delivery but when running the Report the count shown under "Messages with Out of Office replies" is still appearing as zero.

The email server and email client used are Microsoft Exchange 2010 and Microsoft Outlook 2010 respectively.

Cause

The detection scheme used by eMessaging for Out Of Office replies, is by scanning the actual words contained in the Subject field of an Out of Office reply.
In a default installation, e-Messaging uses the following three subject line text values to determine if an inbound message is an “Out of Office” message:
Out of Office 
Not in Office 
Out of Town


In Exchange / Outlook 2010, the Subject field of Out Of Office reply always starts with a text of "Automatic Reply", which is not part of the list of accepted text values above. This is the reason why e--Messaging fails to detect the Out of Office reply.

Resolution

UPDATED: October 31, 2017
The list of acceptable text values for Out of Office replies is maintained in one of the editable configuration files named inbound-observer.properties.
This file can be found in <install_path>/core.war/WEB-INF/classes.

Within the file, we will need to modify one of its lines to be as follow (Note how we append ";Automatic Reply" to the end of the line):
inbound.outOfOffice.subject=Out of Office;Not in Office;Out of Town;Automatic Reply

Description of the inbound.outOfOffice.subject setting above:
A semicolon separated list of subject line text values that e-Messaging uses to determine if an inbound message is an “Out of Office” message. This is used for reporting purposes. Values are case insensitive. These settings allow e-Messaging to report on “Out of Office” messages in any language.