VERIFIED SOLUTION i

What to do when 'Launch on date specified' option for a campaign in Portrait HQ 2.0 does not work?


 

Issue

Campaigns in Portrait HQ 2.0 cannot be launched automatically with the 'Launch on date specified' option.

User-added image
 

Cause

Campaign approval is an optional setting that allows you to control the campaign creation and launch process via user permissions.
It is a setting that once enabled applies to all campaigns. Only Portrait HQ users that have been granted the 'approve campaign' permission are allowed to approve the campaign.

Setting permission for users in Dialogue Admin:

User-added image

To configure campaign approval:

1. Open the web.config file which can be found in <install directory>\PST\Portrait Shared Server\Marketing HQ\.
2. Set the CampaignApprovalEnabled parameter to True.

Once enabled, all campaign changes will require approval by Portrait HQ users who have permissions to approve campaigns.

Then, the 'Launch on date specified' option should work.

Resolution

UPDATED: April 18, 2017
Only users on Portrait HQ 2.0 that do not use campaign approval should use Patch-33695.
The patch affects SSIS package for that version. The issue is fixed in Portrait HQ 2.1 hence the patch should not be used there.