VERIFIED SOLUTION i
X

MapInfo Professional 12.5.x 64-bit has corrupted menu/ribbon state

Issue

MapInfo Pro 12.5 x64 has corrupted menu/ribbon state. When launched, not all or possibly any of the Tab Groups on the Ribbon appear or they appear corrupt.
 

Cause

This can occur if there is a .NET or C++ upgrade and MI Pro is open during the update, as well as for numerous other possible reasons.
 

Resolution

UPDATED: April 10, 2017


With MI Pro closed, open windows Explorer and navigate to
C:\Users\user name\AppData\Local\MapInfo\MapInfo\Professional\1250
and then rename 4 files, by adding ".old" to the extension:

MapInfoPro.DockingState.xml
MapInfoPro.RibbonState.xml
MICommandBarState.xml
MIDockingWindowsState.xml


Then re-start MapInfo Professional and those files should be re-built automatically to resolve the issue.

Environment Details


 

Downloads

  • No Downloads