VERIFIED SOLUTION i
X

Resolve Spectrum Data Flow not exposed in Management Console, exposed in Enterprise Designer

Issue

A custom service dataflow is not exposed in the Management Console, but is exposed in the Enterprise Designer.

 

Cause

There appeared to be a cached corruption within the Spectrum server. The issue still persisted even after attempting to unexposed, then expose the service. 

Resolution

UPDATED: March 30, 2017


Workaround is to utilize more than one Spectrum server (depending on which server is having issues, you will interchange the servers listed below), please follow the steps below:
  1. Stop the Spectrum server on both servers Production & QA
  2. On the Production server, navigate to the \server\app\repository\store
    1. Move/Relabel databases to databases.backup.
    2. Copy the databases directory from server\app\repository on the QA server.
  3. Restart Spectrum on both servers and verify the changes have helped.

If troubleshooting did not resolve the issue, contact technical support.

Environment Details

Product Feature: Spectrum Server

Operating System: Solaris
 

Downloads

  • No Downloads