"Internet not detected" when using PC Meter Connect on the mailstation2 and DM100i-DM475

Check your settings, your network configurations, and your PC Meter Connect version to resolve the "Internet not detected" message on the mailstation2, DM100i, DM125, DM300C, DM400C and DM475.
Products affected: mailstation2™, DM100®i, DM125™, DM300C™, DM400C™, DM475™, PC Meter Connect™

Issue

PC Meter Connect displays the message "Internet not detected."

Cause

PC Meter Connect cannot detect the internet and the Pitney Bowes Data Center.

Resolution

Solution 1: Check to ensure that you have the latest version of PC Meter Connect

  1. The latest version of PC Meter Connect desktop application is 05.00.0081.
  2. Right-click on the PC Meter Connect system tray icon (small icons by the clock).
    PC Meter Connect icon
  3. Select About PC Meter Connect.
  4. If you do not have the latest version, uninstall and reinstall it:
    1. Right-click on the system tray icon and select Exit.
    2. Unplug your USB cable from your meter and your computer.
      connect your meter and your laptop
    3. Unplug your power cord from the back of your meter.
      connect your laptop and meter and plug in the power cord
    4. Select Windows Start > Control Panel > Programs and Features.
    5. Select PC Meter Connect and select Uninstall.
      1. Download and install the latest version of PC Meter Connect.
  5. If you reinstalled PC Meter Connect, restart your meter and your computer:
    1. Unplug your power cord.
    2. Wait one full minute.
    3. Plug your power cord back in; ensure that you plug it directly into a wall outlet.
    4. Restart your computer by closing all open programs and selecting Shut down from the Windows Start menu.
    5. Once your computer has completely shut down, turn it back on.
    6. Attempt your connection again.

If this does not resolve your issue, then try Solution 2.

Solution 2: Configure your network properly

Configure your network to allow the meter to communicate with the Pitney Bowes Data Center. Have your IT department review Networking and connectivity details for mailstation2, DM100i-DM475 to ensure compatibility.

If you still have issues, try Solution 3.

Solution 3: Check your settings

Follow these steps on your computer:

  1. Open the Windows Control Panel.
  2. Select Network and Internet > Internet Options or just Internet Options (options vary depending on your Control Panel configuration).
  3. Select the Connections tab.
  4. Select LAN Settings.
  5. Ensure that you check both boxes:
    • Automatically detect settings
    • Use automatic configuration script
    Note: Contact your IT department for the address for the script or additional information about your network configuration.
  6. Select OK.

If you need further assistance, please use the Contact Us options below.

UPDATED: 02 October 2023