VERIFIED SOLUTION i

Resolve issue where the Street Name is not Retrieved Following Address Search for a Customer Enquiry in Confirm

Product Feature: Customer Services

Issue

Looking up an address, for example for a Customer Enquiry, from within the address form and then performing a search based on the Street Name a list of matching roads are offered in the  Central Site Register Lookup with which the user is presented (CustEnq_001.jpg).

After selecting a street name from the list, it is then not displayed in the Street Name field (CustEnq_002.jpg) back in the Address screen.

Cause

The street name has not been entered in the Address field within the Central Site Register. 

Resolution

UPDATED: October 6, 2017
In the first screenshot we see the Central Site Register lookup and we see 'site name + locality name + town name + county name' in Name column. In the second screenshot it is setting 'locality name' and 'town name' retrieved back to the Address screen. This is the correct behavior. 

For the Street Name field of the Address screen to be populated you need to have the Street entered in the Address Field within the Central Site Register (Main menu -> Site Register -> Central Site Register).