VERIFIED SOLUTION i

Resolve issue while creating interactive letter and submitting it in EngageOne correspondent

Product Feature: Interactive Correspondent

Operating System: Microsoft Windows XP Professional

Database: Microsoft SQL server 2008 r2

IE:  8.0.6001

JBoss(application server):  jboss-5.1.0.GA

Java:  jdk1.6.0_45

EngageOne:  EngageOne_Build_GA-3.1.0.23498.40
 

Issue

Issue while creating interactive letter and submitting it in the EngageOne correspondent.

Error is coming at three stages:

While selecting the template & opening the same in EngageOne correspondent

User-added image

While saving it after making changes to editable paragraph

User-added image

Cause

Error 1: No such lexicon or index for language USA. Select a new language

Issue with the spell checker, which is configured on the server (EngageOne Admin).

Error 2: Speller XML

Issue with the browser cache

Resolution

UPDATED: April 21, 2017
Issue 1: No such lexicon or index for language USA. Select a new language
 
Resolution:  Spell error and dictionary errors can be resolved by starting run.bat as below :
                           run.bat -b 0.0.0.0 -c default 

Issue 2: Speller XML

Resolution:  
Usually this issue is resolved  by clearing browser cache.
                    The IPE Cache is located in the user 'TEMP' folder.

Note: Close all Internet Explorer windows before deleting the contents of the IPE cache. Retry to see if the issue occurs again.