VERIFIED SOLUTION i

Understanding the error message "Could not find a part of the path 'xxxxxx'." in Confirm


 

Issue

The Task Processor logs have entries that say 'Could not find a part of the path...'.

Here are a couple of examples:

Error message "Tenant ID:[Confirm] Directory /xxxxxxx/ not found or created : Could not find a part of the path 'xxxxxxx'." encountered in the Task Processor logs, where xxxxxxxis the file path.

Error found in Street Works Transfer: Could not find a part of the path '\\OnDemand.Confirm.Co.Uk\Production\Transfer\Agents\EToN\Export\XmlFiles\Sent'.

 

Cause

The Task Processor error uses file directory settings on the Street Works Transfer Settings screen.  If these paths are not accessible then this error will be displayed.
 

Resolution

UPDATED: July 13, 2018
Check the file directory settings on the Street Works Transfer Settings screen and either correct the file location or remove them if not required.

The error is also generated if access to the path is not accessible.